If connectors already installed then you can change the selected one at: Window-The error message explains the problem and provides information how to resolve the problem.

If you use Subversive on a non-Windows platform, you need to install pure-Java SVNKit connector and select it on the Window-SVN Connector dialog.

If you have any ideas about the reason of the problem - please let us know. I use this plug-in few years and install the the version when I install the new Eclipse.

updating subclipse-21updating subclipse-45updating subclipse-86

On MAC and Linux you will see only pure Java SVNKit connectors.

We hope that it will help you to make "safe" installs. I have used it on eclipse 3.6 and 3.7 for longer now.

This is the official info from the Subversive team regarding the installation problem that happens on Oxygen.

After that I could install SVN kit connector without any problems. I then tried to access the Subversive 4.0 update site, same problem. It looks like they added a bug where the directory dividers use a backslash '\' instead of a forward slash preventing the tools from finding the right files to compare.

If connectors already installed then you can change the selected one at: Window-I got the same error time ago when I tried to install Windows connectors on non-windows environment. I have tried different kinds of plug ins for eclipse workbench.

As it was suggested in the discussion, you have to install SVNKit that is pure-Java and works on all environments. There are different type of software available but all are not worthy as they used to be.

I wanted to give Oxygen a try, but I will have to wait until the SVN plugin is available. Eclipse doesnot show svn connector discovery dialog box after subversive installation.

Also if tried to install manually it shows http error and internet connection problem please check your connection and try again. This problem occurs with every version of eclipse in my win-32 bit system.please find me a solution Hi Julien, The Neon version (4.0) distributes SVN 1.8 and 1.9 connectors only.

For example, if you install Subversive on Windows x86 you will see pure Java SVNKit connectors and Java HL connectors for x86.